<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>Found on ebay: Porsche 944 Rothmans Turbo Cup driven by Ron Fellows</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />

		<style type="text/css">
			.slide-excerpt { width: 50%; }
			.slide-excerpt { bottom: 0; }
			.slide-excerpt { right: 0; }
			.flexslider { max-width: 920px; max-height: 400px; }
			.slide-image { max-height: 400px; }
		</style>
		<style type="text/css">
			@media only screen
			and (min-device-width : 320px)
			and (max-device-width : 480px) {
				.slide-excerpt { display: none !important; }
			}
		</style> <link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Garage &raquo; Feed" href="http://thegarageblog.com/garage/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Garage &raquo; Comments Feed" href="http://thegarageblog.com/garage/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Garage &raquo; Found on ebay: Porsche 944 Rothmans Turbo Cup driven by Ron Fellows Comments Feed" href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/feed/" />
<link rel="canonical" href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thegarageblog.com\/garage\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='magazine-pro-theme-css'  href='http://thegarageblog.com/garage/wp-content/themes/magazine-pro/style.css?ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900&#038;ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='http://thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=120&#038;height=120&#038;ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://thegarageblog.com/garage/wp-content/plugins/jetpack/css/jetpack.css?ver=4.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='http://thegarageblog.com/garage/wp-content/plugins/genesis-responsive-slider/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/prototype/1.7.1.0/prototype.js?ver=1.7.1'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js?ver=1.9.0'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/effects.js?ver=1.9.0'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/lightbox-2/lightbox.js?ver=1.8'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/themes/magazine-pro/js/entry-date.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/themes/magazine-pro/js/responsive-menu.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='http://thegarageblog.com/garage/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thegarageblog.com/garage/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://thegarageblog.com/garage/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthegarageblog.com%2Fgarage%2Ffound-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thegarageblog.com/garage/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthegarageblog.com%2Fgarage%2Ffound-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows%2F&#038;format=xml" />

	<!-- begin lightbox scripts -->
	<script type="text/javascript">
    //<![CDATA[
    document.write('<link rel="stylesheet" href="http://thegarageblog.com/garage/wp-content/plugins/lightbox-2/Themes/Black/lightbox.css" type="text/css" media="screen" />');
    //]]>
    </script>
	<!-- end lightbox scripts -->
<meta name="google-site-verification" content="K-D3soNXauQlQDAPCr2aP0FImM9EIfv1KycK7ULxEC8" />
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<link rel="icon" href="http://thegarageblog.com/garage/wp-content/themes/magazine-pro/images/favicon.ico" />
<link rel="pingback" href="http://thegarageblog.com/garage/xmlrpc.php" />
<style type="text/css">.site-title a { background: url(http://thegarageblog.com/garage/wp-content/uploads/TG-header-on-white.jpg) no-repeat !important; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Found on ebay: Porsche 944 Rothmans Turbo Cup driven by Ron Fellows" />
<meta property="og:url" content="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/" />
<meta property="og:description" content="The late Eighties and early Nineties were a very special in North American road racing history. In Canada and the USA, there were several healthy showroom stock series that kept fans on their feet …" />
<meta property="article:published_time" content="2010-11-05T19:10:07+00:00" />
<meta property="article:modified_time" content="2010-11-05T19:10:07+00:00" />
<meta property="og:site_name" content="The Garage" />
<meta property="og:image" content="http://thegarageblog.com/garage/wp-content/uploads/porsche35-4-500x332.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<!-- 
			Plugin: Super Simple Google Analytics 
	Plugin URL: Super Simple Google Analytics


	-->

<script type="text/javascript">
	  var _gaq = _gaq || [];
	  _gaq.push(['_setAccount', 'UA-15775362-5']);
	  _gaq.push(['_trackPageview']);
	
	  (function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	  })();
	</script></head>
<body class="post-template-default single single-post postid-13868 single-format-standard custom-header header-image content-sidebar" itemscope itemtype="http://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://thegarageblog.com/garage/">The Garage</a></p><p class="site-description" itemprop="description">The Garage: Your daily dose of automotive news, reviews and motorsports coverage</p></div><div class="widget-area header-widget-area"><section id="text-10" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TGG responsive header -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4693375559701553"
     data-ad-slot="9200976535"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
</div></div></header><nav class="nav-secondary" itemscope itemtype="http://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary-nav" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-15553" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-15553"><a href="http://thegarageblog.com/garage/about/" itemprop="url"><span itemprop="name">About</span></a>
<ul class="sub-menu">
	<li id="menu-item-21485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21485"><a href="http://thegarageblog.com/garage/a-word-about-guest-posts/" itemprop="url"><span itemprop="name">A word about guest posts</span></a></li>
	<li id="menu-item-15551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15551"><a href="http://thegarageblog.com/garage/contact/" itemprop="url"><span itemprop="name">Contact</span></a></li>
</ul>
</li>
<li id="menu-item-15550" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15550"><a href="http://thegarageblog.com/garage/friends/" itemprop="url"><span itemprop="name">Friends</span></a></li>
<li id="menu-item-15554" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15554"><a href="http://thegarageblog.com/garage/archives/" itemprop="url"><span itemprop="name">Archives</span></a></li>
<li id="menu-item-15555" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15555"><a href="http://thegarageblog.com/garage/photo-galleries/" itemprop="url"><span itemprop="name">Galleries</span></a></li>
<li id="menu-item-15561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15561"><a href="http://thegarageblog.com/garage/blog/" itemprop="url"><span itemprop="name">Blog</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-13868 post type-post status-publish format-standard category-memorabilia category-racing tag-944-turbo tag-mont-tremblant tag-mosport tag-porsche tag-ron-fellows tag-rothmans tag-turbo-cup entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Found on ebay: Porsche 944 Rothmans Turbo Cup driven by Ron Fellows</h1> 
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2010-11-05T11:10:07+00:00">November 5, 2010</time> by <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/#comments">10 Comments</a></span> </p></header><div class="entry-content" itemprop="text"><p><a href="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg" rel="lightbox[13868]"><img data-attachment-id="13869" data-permalink="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/porsche35-4/" data-orig-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg?fit=1000%2C664" data-orig-size="1000,664" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;11&quot;,&quot;credit&quot;:&quot;Earl L. Seiler&quot;,&quot;camera&quot;:&quot;NIKON D300S&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1287759149&quot;,&quot;copyright&quot;:&quot;2010&quot;,&quot;focal_length&quot;:&quot;20&quot;,&quot;iso&quot;:&quot;320&quot;,&quot;shutter_speed&quot;:&quot;0.00125&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="porsche35-4" data-image-description="" data-medium-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg?fit=300%2C199" data-large-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg?fit=500%2C332" src="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg?resize=500%2C332" alt="" title="porsche35-4" class="aligncenter size-large wp-image-13869" srcset="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg?resize=500%2C332 500w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg?resize=300%2C199 300w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/porsche35-4.jpg?w=1000 1000w" sizes="(max-width: 500px) 100vw, 500px" data-recalc-dims="1" /></a></p>
<p>The late Eighties and early Nineties were a very special in North American road racing history. In Canada and the USA, there were several healthy showroom stock series that kept fans on their feet at race tracks across the continent. Of those series, the two most exciting were the Player&#8217;s Challenge for Camaros and Firebirds and the Rothmans Porsche series. These two series stand out not only because of the depth of talent and close fought battles, but also because of the incredible personalities driving the cars.</p>
<p>One of the most endearing and enduring personalities of both of those series was NASCAR road course ace Ron Fellows. As a working driver, Big Ron would often miss qualifying due to other races (he still does that today) and would work his way from the back of the grid, up to the podium. The car you see above is the car that Fellows drove in the 1990 Rothmans Turbo Cup series. In &#8217;88 and &#8217;89, it was raced by Ted Powell. The &#8217;90 season ended in Halifax at the Moosehead Grand Prix. During the race, Fellows was taken out by Uli Bieri and backed the car hard into the concrete barriers. The fuel cell ruptured and the car caught fire.</p>
<p>Over the past 15 years, the car has been restored to as raced condition. In fact, the factory sealed engine still wears the series seals. As of this writing, there are <a href="http://cgi.ebay.com/ebaymotors/Porsche-944-Rothmans-Turbo-Cup-Ron-Fellows-Race-History_W0QQcmdZViewItemQQ_trkparmsZalgoQ3dLVIQ26ituQ3dUCIQ26otnQ3d4Q26poQ3dLVIQ26psQ3d63Q26clkidQ3d4742289785482245159QQ_trksidZp5197Q2em7QQcategoryZ98064QQitemZ130450669079#ht_2389wt_793">3 days left on the auction</a>, where the car has a buy it now price of $130,000. To say this car is a unique piece of Canadian racing history would be an understatement. What makes it even more unique is the fact that the car comes with all of the original documentation and many of the spares that were supplied to competitors by the factory.<br />
<span id="more-13868"></span><br />
As a relatively recent series, much of the media surrounding the series, along with the stories of those involved still exist meaning that the racing history of this car is far more intact than that of some older race cars.</p>
<p>Video of the Ron Fellow&#8217;s crash at the Moosehead Grand Prix:</p>
<p><object width="480" height="385"><param name="movie" value="http://www.youtube.com/v/WCsGKc6NBdI?fs=1&amp;hl=en_US"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/WCsGKc6NBdI?fs=1&amp;hl=en_US" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed></object></p>
<p>Notice the old school chivalry as John Graham stopped on track to help get Fellows out of the burning car.</p>
<p><!--Ads2--></p>
<p>Ray Johnson gives a bit of background about the events leading up to the crash:<br />
<em>My brother and I were the Chief marshals for the duration of the Moosehead GP&#8217;s run in Halifax. We had a huge fight with the Course designer and race organizers about the placement of the marshal stand which originally was to be placed at the exact point of impact. That fight ended at 2 am when we walked off the site, during Friday set up telling the Clerk of the Course that we would refuse to deploy marshals on race day if the placement was not shifted further to the left (Camera&#8217;s left) and out of harm&#8217;s way.  It was redone properly by morning. Had it not been done, people would have been injured because the impact was so hard, it drove the jersey barrier well back into the area where the stand was to have been placed. This incident was a vindication, albeit not a great one. At least Ron got out intact. The marshals, Paul Napier and others did an amazing job of putting the car out.</em></p>
<p>Corner marshal Paul Napier recalls:<br />
<em>I distinctly remember us standing there with our extinguisher nozzles poked through the chain link fence spraying down the flames, while noticing un-ignited gasoline flowing in at us under the barriers and pooling around our feet. Very &#8230; volatile feeling &#8230; to use a phrase! It struck me how the grand stand broke out in applause when it was all over, like the end of a scene in a Broad Way play. I know they were applauding out of relief to see it all turn out well, but it was surreal to observe the event as Ã¢â‚¬Å“part of the event Ã¢â‚¬Å“ and then hear the crowd&#8217;s reaction.</em></p>
<p>Brad Brown was the Rothmans series director in 1990 and gives more details of the race:<br />
<em>John Graham was racing the Moosehead sponsored Porsche and was also the promoter of the event. He stopped on the track and got Ron out of the car. As I recall, the impact moved the concrete barrier back about 4 feet and the event was stopped for quite a while for repairs. The promoter decided to finish the remaining races on the schedule before letting us resume and our race had to be given the checkered prematurely because it was dark. Unfortunately, the starter was affected by the darkness as well and threw the flag at the wrong Denon car. David Tennyson was leading but Doug Griesbach was running close to last if not last. Then Tennyson tangled with another car on the last lap and crashed giving the win to Bill Adam. It took me a day to wade through the FIA yellow book and find out that when the flag is given to the wrong car the results go back to the previous lap and so Tennyson won after all.</em></p>
<p>[nggallery id=378]</p>
<p>The seller of #35 had also dug up video of a couple of other races from the 1990 series, which show Ron Fellows proving why he is a fan favorite as he storms through the pack in #35.</p>
<p>Round 3 was at <a href="http://thegarageblog.com/garage/2010-vw-gti-the-spirit-of-the-original-lives-on/">Mont Tremblant</a><br />
<object width="480" height="385"><param name="movie" value="http://www.youtube.com/v/iDM-BwwZB8Q?fs=1&amp;hl=en_US"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/iDM-BwwZB8Q?fs=1&amp;hl=en_US" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed></object></p>
<p>Round 4 was at <a href="http://thegarageblog.com/garage/2010-grand-prix-of-mosport-an-overview/">Mosport</a> and was actually a supporting race for the 24 hour Firehawk race. Mrs. Grant and I were crewing for Kat Teasdale&#8217;s Firehawk series Trans Am that weekend and even after a 24 hour race, there was plenty of excitement around the Rothmans series. Watching Ron Fellows and Richard Spenard battle side by side through corners 8, 9 AND 10 is nothing short of spectacular!<br />
<object width="480" height="385"><param name="movie" value="http://www.youtube.com/v/Y487sBUILTY?fs=1&amp;hl=en_US"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/Y487sBUILTY?fs=1&amp;hl=en_US" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="480" height="385"></embed></object></p>
<p>If you&#8217;ve got an extra 130 grand burning a hole in your jeans, this could be your chance to own a true piece of Canadian racing history!</p>
<p><!--Ads1--></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-13868" class="share-twitter sd-button share-icon no-text" href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-13868" class="share-facebook sd-button share-icon no-text" href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-13868" class="share-google-plus-1 sd-button share-icon no-text" href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-1975162-13868-58e124c7bb1d0' data-src='//widgets.wp.com/likes/#blog_id=1975162&amp;post_id=13868&amp;origin=thegarageblog.com&amp;obj_id=1975162-13868-58e124c7bb1d0' data-name='like-post-frame-1975162-13868-58e124c7bb1d0'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div><div class='yarpp-related'>
<h3>Related posts:</h3>
<div class="yarpp-thumbnails-horizontal">
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/the-car-that-started-it-all/' title='The car that started it all'>
<span class="yarpp-thumbnail-default"><img src="https://i2.wp.com/thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/default.png" data-recalc-dims="1"/></span><span class="yarpp-thumbnail-title">The car that started it all</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/searching-for-signal-in-downtown-toronto/' title='Searching for signal in downtown Toronto'>
<span class="yarpp-thumbnail-default"><img src="https://i2.wp.com/thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/default.png" data-recalc-dims="1"/></span><span class="yarpp-thumbnail-title">Searching for signal in downtown Toronto</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/porsche-canada-treats-loyal-customers-to-an-evening-with-rs-spyder/' title='Porsche Canada treats loyal customers to an evening with RS Spyder'>
<span class="yarpp-thumbnail-default"><img src="https://i2.wp.com/thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/default.png" data-recalc-dims="1"/></span><span class="yarpp-thumbnail-title">Porsche Canada treats loyal customers to an evening with RS Spyder</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/what-does-blue-mean-to-you/' title='What does blue mean to you?'>
<span class="yarpp-thumbnail-default"><img src="https://i2.wp.com/thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/default.png" data-recalc-dims="1"/></span><span class="yarpp-thumbnail-title">What does blue mean to you?</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/canadian-legends-of-motorsport-to-be-honored-at-the-mobil-1-presents-the-grand-prix-of-mosport/' title='Canadian Legends of Motorsport to be honored at the Mobil 1 presents the Grand Prix of Mosport'>
<span class="yarpp-thumbnail-default"><img src="https://i2.wp.com/thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/default.png" data-recalc-dims="1"/></span><span class="yarpp-thumbnail-title">Canadian Legends of Motorsport to be honored at the Mobil 1 presents the Grand Prix of Mosport</span></a>
</div>
</div>
<!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/"
    dc:identifier="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/"
    dc:title="Found on ebay: Porsche 944 Rothmans Turbo Cup driven by Ron Fellows"
    trackback:ping="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/trackback/" />
</rdf:RDF>-->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://thegarageblog.com/garage/category/memorabilia/" rel="category tag">Memorabilia</a>, <a href="http://thegarageblog.com/garage/category/racing/" rel="category tag">Racing</a></span> <span class="entry-tags">Tagged With: <a href="http://thegarageblog.com/garage/tag/944-turbo/" rel="tag">944 turbo</a>, <a href="http://thegarageblog.com/garage/tag/mont-tremblant/" rel="tag">mont tremblant</a>, <a href="http://thegarageblog.com/garage/tag/mosport/" rel="tag">mosport</a>, <a href="http://thegarageblog.com/garage/tag/porsche/" rel="tag">porsche</a>, <a href="http://thegarageblog.com/garage/tag/ron-fellows/" rel="tag">ron-fellows</a>, <a href="http://thegarageblog.com/garage/tag/rothmans/" rel="tag">rothmans</a>, <a href="http://thegarageblog.com/garage/tag/turbo-cup/" rel="tag">turbo cup</a></span></p><div class="after-entry widget-area"><div class="wrap"><section id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TG after post responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4693375559701553"
     data-ad-slot="6107909332"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
</div></div></footer></article><div class="entry-comments" id="comments"><h3>Comments</h3><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-171481">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/ab488f93c6fa1de5f7071c76279630f3?s=100&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/ab488f93c6fa1de5f7071c76279630f3?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name"><a href="http://www.my-beckers-story.blogspot.com" class="comment-author-link" rel="external nofollow" itemprop="url">Brad</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-05T12:58:14+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-171481" class="comment-time-link" itemprop="url">November 5, 2010 at 12:58 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>I was probably at that race when he ran at Mosport, cool find! These guys really raced these 944&#039;s hard, great cars, great racing! </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=171481#respond' onclick='return addComment.moveForm( "comment-171481", "171481", "respond", "13868" )' aria-label='Reply to Brad'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment byuser comment-author-admin-2 bypostauthor odd alt thread-odd thread-alt depth-1" id="comment-171494">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/8f60c531e57bd3e076e9f2b0ba2b47dc?s=100&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/8f60c531e57bd3e076e9f2b0ba2b47dc?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name"><a href="http://thegarageblog.com" class="comment-author-link" rel="external nofollow" itemprop="url">Gary Grant</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-05T14:03:44+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-171494" class="comment-time-link" itemprop="url">November 5, 2010 at 2:03 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>These guys raced so hard and were so much fun to watch. To see guys who are so talented and have so much trust in the other guy that they can go 2 wide through consecutive corners was so much fun! </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=171494#respond' onclick='return addComment.moveForm( "comment-171494", "171494", "respond", "13868" )' aria-label='Reply to Gary Grant'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment even thread-even depth-1" id="comment-171527">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/1985026d9be1d07b086a3526aca797dd?s=100&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/1985026d9be1d07b086a3526aca797dd?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name"><a href="http://www.paulnapierdesign.ca" class="comment-author-link" rel="external nofollow" itemprop="url">Paul Napier</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-05T17:24:17+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-171527" class="comment-time-link" itemprop="url">November 5, 2010 at 5:24 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Gary &#8211; Thanks for putting together such a great story about this race and allowing myself and Ray Johnson to lend our memories.  A must send a big Shout Out to Mr. Paul Chenard for bringing this to my attention and forwarding our comments to you. </p>
<p>Thank You Gary, Brad &amp; Paul &mdash;Cheers Gents 🙂 </p>
<p>Paul Napier </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=171527#respond' onclick='return addComment.moveForm( "comment-171527", "171527", "respond", "13868" )' aria-label='Reply to Paul Napier'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-171823">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/bb020d8b83795dec6d0c3853c1c13a2b?s=100&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/bb020d8b83795dec6d0c3853c1c13a2b?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name"><a href="http://franczakdrive.com" class="comment-author-link" rel="external nofollow" itemprop="url">Chris Bye</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-07T06:29:18+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-171823" class="comment-time-link" itemprop="url">November 7, 2010 at 6:29 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Hey Gary, Thanks much! Brings back memories of a time when Canada had some of the best road racing (and drivers) in the world. Days probably not to return &#8211; at least not in my lifetime&#8230; </p>
<p>Chris Bye </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=171823#respond' onclick='return addComment.moveForm( "comment-171823", "171823", "respond", "13868" )' aria-label='Reply to Chris Bye'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment byuser comment-author-admin-2 bypostauthor even thread-even depth-1" id="comment-171861">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/8f60c531e57bd3e076e9f2b0ba2b47dc?s=100&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/8f60c531e57bd3e076e9f2b0ba2b47dc?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name"><a href="http://thegarageblog.com" class="comment-author-link" rel="external nofollow" itemprop="url">Gary Grant</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-07T16:10:43+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-171861" class="comment-time-link" itemprop="url">November 7, 2010 at 4:10 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Chris, it was indeed a &quot;golden age&quot; for racing in Canada. You should be proud of the mark your family left on the sport and continues to do today. </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=171861#respond' onclick='return addComment.moveForm( "comment-171861", "171861", "respond", "13868" )' aria-label='Reply to Gary Grant'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-171930">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/b9fc1f75520ac2f0486781bca0ab93a2?s=100&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/b9fc1f75520ac2f0486781bca0ab93a2?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name">Leighton Irwin</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-08T07:51:53+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-171930" class="comment-time-link" itemprop="url">November 8, 2010 at 7:51 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>From another point of view, although it was great racing, it hurt regular Region racing big time. The &#8216;Ignition Key&#8217; series, GM, Porsche and Honda, got so much attention and track time the other classes were relegated to second class citizens.<br />
In 87 were running F4 and at Mosport would get 15 minutes of practice, 10 minutes of qualifying, an 8 or 10 lap race and a 15 lap race.<br />
We were developing a fuel injected Yamaha engined car, that as it turned out had a major oiling problem Yamaha corrected the next year. The lack of track time hampered our efforts so much we ran at Waterford Hills, Mich. more than we did at Mosport which was only 60 miles from our shop. At Waterford we got 2 practice sessions, qualifying, a Sunday warmup and 3 races.<br />
It was one of the main reasons Judy quit at the end of 87. We just felt it was not worth it for so little track time and although Waterford was fun it was a 4 hour drive, assuming the border was quick.<br />
After the 3 series died it took a long time for Regional racing to recover.</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=171930#respond' onclick='return addComment.moveForm( "comment-171930", "171930", "respond", "13868" )' aria-label='Reply to Leighton Irwin'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment even thread-even depth-1" id="comment-172827">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/42af97ad18436e536727ecae92393527?s=100&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/42af97ad18436e536727ecae92393527?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name">Stefan Wiesen</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-14T05:05:47+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-172827" class="comment-time-link" itemprop="url">November 14, 2010 at 5:05 am</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Here is another one for sale, a non-turbo Rothmans car of the earlier years.  <a href="http://cgi.ebay.ca/Porsche-944-/180587276764?pt=US_Cars_Trucks&amp;hash=item2a0bd729dc" rel="nofollow"></a><a href="http://cgi.ebay.ca/Porsche-944-/180587276764?pt=U" rel="nofollow">http://cgi.ebay.ca/Porsche-944-/180587276764?pt=U</a>&#8230;<br />
Cheers </p>
<p>Stefan </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=172827#respond' onclick='return addComment.moveForm( "comment-172827", "172827", "respond", "13868" )' aria-label='Reply to Stefan Wiesen'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-173334">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://0.gravatar.com/avatar/67be268dd0e0c20048252d930e5f75ea?s=100&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/67be268dd0e0c20048252d930e5f75ea?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name"><a href="http://www.pca.org" class="comment-author-link" rel="external nofollow" itemprop="url">Shannon</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2010-11-17T12:52:14+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-173334" class="comment-time-link" itemprop="url">November 17, 2010 at 12:52 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>I echo the thanks of others for putting this together.  I have always been fascinated by this series and was fortunate to buy and race an &#039;86 Rothmans car.  I have since bought another 944 race car and am looking for a good home for the 86 Rothmans.  This is an NA car and was raced by Brian Malcom back in 1986 and 87.  If interested check out the advertisement on Porsche Club of America website. </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=173334#respond' onclick='return addComment.moveForm( "comment-173334", "173334", "respond", "13868" )' aria-label='Reply to Shannon'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment even thread-even depth-1" id="comment-413272">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://2.gravatar.com/avatar/bb30ee0464e734cc6ced5d4beaabcb85?s=100&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/bb30ee0464e734cc6ced5d4beaabcb85?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name">Crook3d</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2013-10-25T21:23:47+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-413272" class="comment-time-link" itemprop="url">October 25, 2013 at 9:23 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>Neat, I sat in that car when I was a little kid. </p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=413272#respond' onclick='return addComment.moveForm( "comment-413272", "413272", "respond", "13868" )' aria-label='Reply to Crook3d'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-936949">
	<article itemprop="comment" itemscope itemtype="http://schema.org/Comment">

		
		<header class="comment-header">
			<p class="comment-author" itemprop="author" itemscope itemtype="http://schema.org/Person">
				<img alt='' src='http://1.gravatar.com/avatar/43668d8c2b063dc62ca7bfcb83608526?s=100&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/43668d8c2b063dc62ca7bfcb83608526?s=200&amp;d=mm&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /><span itemprop="name">Terry Dale</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time" datetime="2017-04-01T12:07:09+00:00" itemprop="datePublished"><a href="http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#comment-936949" class="comment-time-link" itemprop="url">April 1, 2017 at 12:07 pm</a></time></p>		</header>

		<div class="comment-content" itemprop="text">
			
			<p>I was the Race Director for that Moosehead Race. The &#8216;Feature Race&#8217; was the AIS _- American IndyCar Series&#8217; that had Robbie Unser and Uncle Jacques Villeneuve on the front row. Their Chief Steward was Roger Ward &#8211; yes, that Roger Ward&#8217; and I asked him at 5:00 PM when we finally cleaned up the mess from Ron&#8217;s crash how many laps he needed to make it  &#8216;a race&#8217;. He answered &#8216;as many as you can give me&#8217; so we started the race at 5:15 as it was getting dark. We checkered it at 5:45 and then scrambled to get the Porsche 944&#8217;s lined up to get their race going. It had to finish at least 50% as it was a championship deciding end-of-season race. The serious challenge was that we had a hard curfew of 6:00 PM and there was no way we could run the 50% before 6:20 PM. My answer was to lock the door to Race Control and turn the clock back 20 minutes. I told everyone to ignore the door no matter what and we ran the race holding our breath. The checkered flag came out in pitch black darkness and we thought we had done it &#8211; until the Denon car clobbered the wall coming to the final flag! We cleaned up the mess as quickly as we could and that was the end of an amazing weekend! There are a whole lot more stories to tell but that one is probably one of the best ones! Also &#8211; there is nothing much better than being sponsored by a brewery! Problems with the neigjhbours? Drop off a couple of flats of Moosehead beer &#8211; problem solved!! Terry Dale, Moosehead Grand Prix, Race Director</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='http://thegarageblog.com/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/?replytocom=936949#respond' onclick='return addComment.moveForm( "comment-936949", "936949", "respond", "13868" )' aria-label='Reply to Terry Dale'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->
</ol></div>
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/garage/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows/comment-page-1/#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=1975162&#038;postid=13868&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.7.1&#038;sig=a96cac40312a2c2f44e18d82ef3e3a5da25aa301#parent=http%3A%2F%2Fthegarageblog.com%2Fgarage%2Ffound-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows%2Fcomment-page-1%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><section id="text-9" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Advertisment</h4>
			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TGG sidebar responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4693375559701553"
     data-ad-slot="3154442931"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
<section id="image-7" class="widget widget_image"><div class="widget-wrap"><div class="jetpack-image-container"><a target="_blank" href="http://thegarageguy.ca"><img src="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg" class="alignnone" data-recalc-dims="1" /></a></div>
</div></section>
<section id="search-4" class="widget widget_search"><div class="widget-wrap"><h4 class="widget-title widgettitle">Find stuff</h4>
<form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" method="get" action="http://thegarageblog.com/garage/" role="search"><meta itemprop="target" content="http://thegarageblog.com/garage/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search the site ..." /><input type="submit" value="Search"  /></form></div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
					<li>
				<a href="http://thegarageblog.com/garage/review-2017-volkswagen-passat/">Review: 2017 Volkswagen Passat</a>
						</li>
					<li>
				<a href="http://thegarageblog.com/garage/2017-nissan-sentra-sr-turbo/">2017 Nissan Sentra SR Turbo</a>
						</li>
					<li>
				<a href="http://thegarageblog.com/garage/this-gti-hillclimb-car-bends-the-laws-of-physics/">This GTI hillclimb car bends the laws of physics</a>
						</li>
					<li>
				<a href="http://thegarageblog.com/garage/b-f-goodrich-launches-winter-ta-ksi-in-canadas-capital/">B.F. Goodrich launches Winter T/A KSI in Canada&#8217;s capital</a>
						</li>
					<li>
				<a href="http://thegarageblog.com/garage/review-2017-toyota-86/">Review: 2017 Toyota 86</a>
						</li>
				</ul>
		</div></section>
		<section id="featured-post-10" class="widget featured-content featuredpost"><div class="widget-wrap"><h4 class="widget-title widgettitle">NEW Feature: World&#8217;s Fastest Car Review</h4>
<article class="post-23100 post type-post status-publish format-standard has-post-thumbnail category-featured-stories category-worlds-fastest-car-review tag-autonomous-car tag-autonomous-volvo tag-gothenburg tag-self-driving-car tag-self-driving-volvo tag-sweden tag-volvo tag-volvo-drive-me tag-volvo-drive-me-project entry"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/" class="alignleft" aria-hidden="true"><img width="100" height="100" src="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?resize=100%2C100" class="entry-image attachment-post" alt="World&#8217;s Fastest Car Review: Volvo Drive Me" itemprop="image" srcset="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?resize=150%2C150 150w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?resize=100%2C100 100w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?zoom=2&amp;resize=100%2C100 200w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?zoom=3&amp;resize=100%2C100 300w" sizes="(max-width: 100px) 100vw, 100px" data-attachment-id="23101" data-permalink="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/drive-me/" data-orig-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?fit=1277%2C711" data-orig-size="1277,711" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="drive me" data-image-description="" data-medium-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?fit=300%2C167" data-large-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?fit=750%2C417" /></a><header class="entry-header"><h2 class="entry-title"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/">World&#8217;s Fastest Car Review: Volvo Drive Me</a></h2><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2014-05-29T10:33:41+00:00">May 29, 2014</time> By <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/#comments">1 Comment</a></span></p></header></article><article class="post-23089 post type-post status-publish format-standard has-post-thumbnail category-featured-stories category-video-links category-worlds-fastest-car-review tag-2014-volkswagen-touareg-tdi tag-diesel tag-eric-novak tag-suv tag-volkswagen tag-vw entry"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/" class="alignleft" aria-hidden="true"><img width="100" height="100" src="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?resize=100%2C100" class="entry-image attachment-post" alt="World&#8217;s Fastest Car Review: Enviro Dad and the VW Touareg TDI" itemprop="image" srcset="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?resize=150%2C150 150w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?resize=100%2C100 100w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?zoom=2&amp;resize=100%2C100 200w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?zoom=3&amp;resize=100%2C100 300w" sizes="(max-width: 100px) 100vw, 100px" data-attachment-id="23090" data-permalink="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/enviro-vw/" data-orig-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?fit=1271%2C702" data-orig-size="1271,702" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="enviro vw" data-image-description="" data-medium-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?fit=300%2C165" data-large-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?fit=750%2C414" /></a><header class="entry-header"><h2 class="entry-title"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/">World&#8217;s Fastest Car Review: Enviro Dad and the VW Touareg TDI</a></h2><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2014-05-26T12:08:19+00:00">May 26, 2014</time> By <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/#respond">Leave a Comment</a></span></p></header></article><article class="post-22940 post type-post status-publish format-standard has-post-thumbnail category-featured-stories category-new-car-reviews category-video-links category-worlds-fastest-car-review tag-savethemanuals tag-mazda tag-mazda-5 tag-mazda5 tag-minivan tag-not-a-minivan tag-save-the-manuals entry"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/" class="alignleft" aria-hidden="true"><img width="100" height="100" src="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=100%2C100" class="entry-image attachment-post" alt="World&#8217;s Fastest Car Review: 2014 Mazda5" itemprop="image" srcset="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=150%2C150 150w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=100%2C100 100w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?zoom=2&amp;resize=100%2C100 200w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?zoom=3&amp;resize=100%2C100 300w" sizes="(max-width: 100px) 100vw, 100px" data-attachment-id="22941" data-permalink="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/wf-m5/" data-orig-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=1275%2C700" data-orig-size="1275,700" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="WF M5" data-image-description="" data-medium-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=300%2C164" data-large-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=750%2C411" /></a><header class="entry-header"><h2 class="entry-title"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/">World&#8217;s Fastest Car Review: 2014 Mazda5</a></h2><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2014-05-08T10:56:36+00:00">May 8, 2014</time> By <span class="entry-author" itemprop="author" itemscope itemtype="http://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/#comments">1 Comment</a></span></p></header></article></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2017 &#x000B7; <a href="http://my.studiopress.com/themes/magazine/">Magazine Pro Theme</a> on <a href="http://www.studiopress.com/">Genesis Framework</a> &#x000B7; <a href="http://wordpress.org/">WordPress</a> &#x000B7; <a href="http://thegarageblog.com/garage/wp-login.php">Log in</a></p></div></footer></div>	<div style="display:none">
	<div class="grofile-hash-map-ab488f93c6fa1de5f7071c76279630f3">
	</div>
	<div class="grofile-hash-map-8f60c531e57bd3e076e9f2b0ba2b47dc">
	</div>
	<div class="grofile-hash-map-1985026d9be1d07b086a3526aca797dd">
	</div>
	<div class="grofile-hash-map-bb020d8b83795dec6d0c3853c1c13a2b">
	</div>
	<div class="grofile-hash-map-b9fc1f75520ac2f0486781bca0ab93a2">
	</div>
	<div class="grofile-hash-map-42af97ad18436e536727ecae92393527">
	</div>
	<div class="grofile-hash-map-67be268dd0e0c20048252d930e5f75ea">
	</div>
	<div class="grofile-hash-map-bb30ee0464e734cc6ced5d4beaabcb85">
	</div>
	<div class="grofile-hash-map-43668d8c2b063dc62ca7bfcb83608526">
	</div>
	</div>
<script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "slide",directionNav: 1,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000    });  });</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/thegarageblog.com\/garage\/found-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows\/":13868};
	</script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<link rel='stylesheet' id='yarppRelatedCss-css'  href='http://thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.7.3' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201713'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Apraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/comment-reply.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/genesis-responsive-slider/js/jquery.flexslider.js?ver=0.9.5'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/thegarageblog.com\/garage\/wp-admin\/admin-ajax.php","nonce":"9da8e468cc","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/thegarageblog.com\/garage\/wp-login.php?redirect_to=http%3A%2F%2Fthegarageblog.com%2Fgarage%2Ffound-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/postmessage.js?ver=4.7.1'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=4.7.1'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=4.7.1'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=4.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
		<iframe src='http://widgets.wp.com/likes/master.html?ver=20160429#ver=20160429' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		
		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=1975162&postid=13868&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=a96cac40312a2c2f44e18d82ef3e3a5da25aa301#parent=http%3A%2F%2Fthegarageblog.com%2Fgarage%2Ffound-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows%2Fcomment-page-1%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=1975162&postid=13868&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=a96cac40312a2c2f44e18d82ef3e3a5da25aa301#parent=http%3A%2F%2Fthegarageblog.com%2Fgarage%2Ffound-on-ebay-porsche-944-rothmans-turbo-cup-driven-by-ron-fellows%2Fcomment-page-1%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201713.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.7.1',blog:'1975162',post:'13868',tz:'-4',srv:'thegarageblog.com'} ]);
	_stq.push([ 'clickTrackerInit', '1975162', '13868' ]);
</script>
</body></html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

 Served from: thegarageblog.com @ 2017-04-02 12:20:23 by W3 Total Cache -->