<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<title>2018 Mazda MX-5 RF on ice</title>

		<style type="text/css">
			.slide-excerpt { width: 50%; }
			.slide-excerpt { bottom: 0; }
			.slide-excerpt { right: 0; }
			.flexslider { max-width: 920px; max-height: 400px; }
			.slide-image { max-height: 400px; }
		</style>
		<style type="text/css">
			@media only screen
			and (min-device-width : 320px)
			and (max-device-width : 480px) {
				.slide-excerpt { display: none !important; }
			}
		</style> <link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Garage Blog &raquo; Feed" href="http://thegarageblog.com/garage/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Garage Blog &raquo; Comments Feed" href="http://thegarageblog.com/garage/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Garage Blog &raquo; 2018 Mazda MX-5 RF on ice Comments Feed" href="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/feed/" />
<link rel="canonical" href="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/thegarageblog.com\/garage\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='magazine-pro-theme-css'  href='http://thegarageblog.com/garage/wp-content/themes/magazine-pro/style.css?ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900&#038;ver=3.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='yarpp-thumbnails-yarpp-thumbnail-css'  href='http://thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/includes/styles_thumbnails.css.php?width=120&#038;height=120&#038;ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://thegarageblog.com/garage/wp-content/plugins/jetpack/css/jetpack.css?ver=6.0' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='http://thegarageblog.com/garage/wp-content/plugins/genesis-responsive-slider/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/prototype/1.7.1.0/prototype.js?ver=1.7.1'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/scriptaculous.js?ver=1.9.0'></script>
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/scriptaculous/1.9.0/effects.js?ver=1.9.0'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/lightbox-2/lightbox-resize.js?ver=1.8'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/themes/magazine-pro/js/entry-date.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/themes/magazine-pro/js/responsive-menu.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='http://thegarageblog.com/garage/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://thegarageblog.com/garage/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://thegarageblog.com/garage/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthegarageblog.com%2Fgarage%2F2018-mazda-mx-5-rf-on-ice%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://thegarageblog.com/garage/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fthegarageblog.com%2Fgarage%2F2018-mazda-mx-5-rf-on-ice%2F&#038;format=xml" />

	<!-- begin lightbox scripts -->
	<script type="text/javascript">
    //<![CDATA[
    document.write('<link rel="stylesheet" href="http://thegarageblog.com/garage/wp-content/plugins/lightbox-2/Themes/Black/lightbox.css" type="text/css" media="screen" />');
    //]]>
    </script>
	<!-- end lightbox scripts -->
<meta name="google-site-verification" content="K-D3soNXauQlQDAPCr2aP0FImM9EIfv1KycK7ULxEC8" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel="icon" href="http://thegarageblog.com/garage/wp-content/themes/magazine-pro/images/favicon.ico" />
<link rel="pingback" href="http://thegarageblog.com/garage/xmlrpc.php" />
<style type="text/css">.site-title a { background: url(http://thegarageblog.com/garage/wp-content/uploads/TG-header-on-white.jpg) no-repeat !important; }</style>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="2018 Mazda MX-5 RF on ice" />
<meta property="og:url" content="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/" />
<meta property="og:description" content="Never one to miss out on an opportunity to have some fun, I decided to take advantage of the recent ice storm in Ontario to do a bit of top down motoring in the 2018 Mazda MX-5 RF. I mean, after I …" />
<meta property="article:published_time" content="2018-04-19T18:44:04+00:00" />
<meta property="article:modified_time" content="2018-04-19T18:44:04+00:00" />
<meta property="og:site_name" content="The Garage Blog" />
<meta property="og:image" content="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?fit=1200%2C713" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="713" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:text:title" content="2018 Mazda MX-5 RF on ice" />
<meta name="twitter:image" content="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?fit=1200%2C713&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@thegarageblog" />
<!-- 
			Plugin: Super Simple Google Analytics 
	Plugin URL: Super Simple Google Analytics


	-->

<script type="text/javascript">
	  var _gaq = _gaq || [];
	  _gaq.push(['_setAccount', 'UA-15775362-5']);
	  _gaq.push(['_trackPageview']);
	
	  (function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	  })();
	</script></head>
<body class="post-template-default single single-post postid-28058 single-format-standard custom-header header-image content-sidebar" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://thegarageblog.com/garage/">The Garage Blog</a></p><p class="site-description" itemprop="description">The Garage: Your daily dose of automotive news, reviews and motorsports coverage</p></div><div class="widget-area header-widget-area"><section id="text-10" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TGG responsive header -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4693375559701553"
     data-ad-slot="9200976535"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
</div></div></header><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary-nav" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-15553" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15553"><a href="http://thegarageblog.com/garage/about/" itemprop="url"><span itemprop="name">About</span></a></li>
<li id="menu-item-15554" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15554"><a href="http://thegarageblog.com/garage/archives/" itemprop="url"><span itemprop="name">Archives</span></a></li>
<li id="menu-item-15551" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-15551"><a href="http://thegarageblog.com/garage/contact/" itemprop="url"><span itemprop="name">Contact</span></a>
<ul class="sub-menu">
	<li id="menu-item-21485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21485"><a href="http://thegarageblog.com/garage/a-word-about-guest-posts/" itemprop="url"><span itemprop="name">A word about guest posts</span></a></li>
</ul>
</li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-28058 post type-post status-publish format-standard has-post-thumbnail category-new-car-reviews category-video-links tag-coupe tag-ice-storm tag-mazda tag-mazda-mx5 tag-mazda-mx5-rf tag-mazda-canada tag-miata tag-ontario tag-roadster tag-winter-driving tag-zoom-zoom entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">2018 Mazda MX-5 RF on ice</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-04-19T14:44:04+00:00">April 19, 2018</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><p><a href="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg" rel="lightbox[28058]"><img data-attachment-id="28061" data-permalink="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/tgg_mx5onice-2-of-6/" data-orig-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?fit=1200%2C713" data-orig-size="1200,713" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;SM-G900W8&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1523793415&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.8&quot;,&quot;iso&quot;:&quot;40&quot;,&quot;shutter_speed&quot;:&quot;0.0037037037037&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tgg_mx5onice (2 of 6)" data-image-description="" data-medium-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?fit=300%2C178" data-large-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?fit=750%2C446" class="aligncenter size-large wp-image-28061" src="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?resize=750%2C446" alt="" width="750" height="446" srcset="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?resize=750%2C446 750w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?resize=300%2C178 300w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?resize=768%2C456 768w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-2-of-6.jpg?w=1200 1200w" sizes="(max-width: 750px) 100vw, 750px" data-recalc-dims="1" /></a></p>
<p>Never one to miss out on an opportunity to have some fun, I decided to take advantage of the recent ice storm in Ontario to do a bit of top down motoring in the 2018 Mazda MX-5 RF. I mean, after I consistently give my colleagues a hard time about driving convertibles with the top up, so I didn&#8217;t really have a choice. What I found was that Winter is no match for Mazda&#8217;s all season sportster.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='640' height='390' src='http://www.youtube.com/embed/IYHemUTyEA0?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>&nbsp;</p>

		<style type='text/css'>
			#gallery-1 {
				margin: auto;
			}
			#gallery-1 .gallery-item {
				float: left;
				margin-top: 10px;
				text-align: center;
				width: 50%;
			}
			#gallery-1 img {
				border: 2px solid #cfcfcf;
			}
			#gallery-1 .gallery-caption {
				margin-left: 0;
			}
			/* see gallery_shortcode() in wp-includes/media.php */
		</style>
		<div data-carousel-extra='{"blog_id":1,"permalink":"http:\/\/thegarageblog.com\/garage\/2018-mazda-mx-5-rf-on-ice\/"}' id='gallery-1' class='gallery galleryid-28058 gallery-columns-2 gallery-size-medium'><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg' rel="lightbox[28058]"><img width="300" height="169" src="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?fit=300%2C169" class="attachment-medium size-medium" alt="" srcset="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?w=1200 1200w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?resize=300%2C169 300w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?resize=768%2C432 768w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?resize=750%2C420 750w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="28065" data-permalink="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/tgg_mx5onice-6-of-6/" data-orig-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?fit=1200%2C675" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;SM-G900W8&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1523793440&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.8&quot;,&quot;iso&quot;:&quot;40&quot;,&quot;shutter_speed&quot;:&quot;0.003125&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tgg_mx5onice (6 of 6)" data-image-description="" data-medium-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?fit=300%2C169" data-large-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-6-of-6.jpg?fit=750%2C422" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg' rel="lightbox[28058]"><img width="300" height="169" src="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?fit=300%2C169" class="attachment-medium size-medium" alt="" srcset="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?w=1200 1200w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?resize=300%2C169 300w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?resize=768%2C432 768w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?resize=750%2C420 750w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="28064" data-permalink="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/tgg_mx5onice-5-of-6/" data-orig-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?fit=1200%2C675" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;SM-G900W8&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1523793434&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.8&quot;,&quot;iso&quot;:&quot;50&quot;,&quot;shutter_speed&quot;:&quot;0.02&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tgg_mx5onice (5 of 6)" data-image-description="" data-medium-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?fit=300%2C169" data-large-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-5-of-6.jpg?fit=750%2C422" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg' rel="lightbox[28058]"><img width="300" height="169" src="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?fit=300%2C169" class="attachment-medium size-medium" alt="" srcset="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?w=1200 1200w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?resize=300%2C169 300w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?resize=768%2C432 768w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?resize=750%2C420 750w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="28063" data-permalink="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/tgg_mx5onice-4-of-6/" data-orig-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?fit=1200%2C675" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;SM-G900W8&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1523793425&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.8&quot;,&quot;iso&quot;:&quot;64&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tgg_mx5onice (4 of 6)" data-image-description="" data-medium-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?fit=300%2C169" data-large-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-4-of-6.jpg?fit=750%2C422" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg' rel="lightbox[28058]"><img width="300" height="169" src="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?fit=300%2C169" class="attachment-medium size-medium" alt="" srcset="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?w=1200 1200w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?resize=300%2C169 300w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?resize=768%2C432 768w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?resize=750%2C420 750w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="28062" data-permalink="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/tgg_mx5onice-3-of-6/" data-orig-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?fit=1200%2C675" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;SM-G900W8&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1523793419&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.8&quot;,&quot;iso&quot;:&quot;50&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tgg_mx5onice (3 of 6)" data-image-description="" data-medium-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?fit=300%2C169" data-large-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/tgg_mx5onice-3-of-6.jpg?fit=750%2C422" /></a>
			</dt></dl><br style="clear: both" />
		</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-28058" class="share-twitter sd-button share-icon no-text" href="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-28058" class="share-facebook sd-button share-icon no-text" href="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-28058" class="share-google-plus-1 sd-button share-icon no-text" href="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-1975162-28058-5ae24f41098db' data-src='https://widgets.wp.com/likes/#blog_id=1975162&amp;post_id=28058&amp;origin=thegarageblog.com&amp;obj_id=1975162-28058-5ae24f41098db' data-name='like-post-frame-1975162-28058-5ae24f41098db'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div><div class='yarpp-related'>
<h3>Related posts:</h3>
<div class="yarpp-thumbnails-horizontal">
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/we-cant-wait-for-spring/' title='We can&#8217;t wait for Spring!'>
<img width="120" height="120" src="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/20170708_133447-e1520353235171.jpg?resize=120%2C120" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/20170708_133447-e1520353235171.jpg?zoom=2&amp;resize=120%2C120 240w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/20170708_133447-e1520353235171.jpg?zoom=3&amp;resize=120%2C120 360w" sizes="(max-width: 120px) 100vw, 120px" data-attachment-id="27953" data-permalink="http://thegarageblog.com/garage/we-cant-wait-for-spring/20170708_133447/" data-orig-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/20170708_133447-e1520353235171.jpg?fit=1200%2C675" data-orig-size="1200,675" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;SM-G900W8&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1499520887&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.8&quot;,&quot;iso&quot;:&quot;40&quot;,&quot;shutter_speed&quot;:&quot;0.000609756097561&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="20170708_133447" data-image-description="" data-medium-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/20170708_133447-e1520353235171.jpg?fit=300%2C169" data-large-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/20170708_133447-e1520353235171.jpg?fit=750%2C422" /><span class="yarpp-thumbnail-title">We can&#8217;t wait for Spring!</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/2017-audi-allroad-quattro-awd-in-action/' title='2017 Audi Allroad Quattro: AWD in Action'>
<span class="yarpp-thumbnail-default"><img src="https://i2.wp.com/thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/default.png" data-recalc-dims="1"/></span><span class="yarpp-thumbnail-title">2017 Audi Allroad Quattro: AWD in Action</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/how-do-i-steer-this-thing/' title='How do I steer this thing?'>
<img width="120" height="120" src="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?resize=120%2C120" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?resize=150%2C150 150w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?resize=100%2C100 100w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?zoom=2&amp;resize=120%2C120 240w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?zoom=3&amp;resize=120%2C120 360w" sizes="(max-width: 120px) 100vw, 120px" data-attachment-id="22466" data-permalink="http://thegarageblog.com/garage/how-do-i-steer-this-thing/wheel-off/" data-orig-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?fit=852%2C463" data-orig-size="852,463" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="wheel off" data-image-description="" data-medium-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?fit=300%2C163" data-large-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/wheel-off.jpg?fit=750%2C407" /><span class="yarpp-thumbnail-title">How do I steer this thing?</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/' title='World&#8217;s Fastest Car Review: 2014 Mazda5'>
<img width="120" height="120" src="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=120%2C120" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=150%2C150 150w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=100%2C100 100w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?zoom=2&amp;resize=120%2C120 240w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?zoom=3&amp;resize=120%2C120 360w" sizes="(max-width: 120px) 100vw, 120px" data-attachment-id="22941" data-permalink="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/wf-m5/" data-orig-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=1275%2C700" data-orig-size="1275,700" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="WF M5" data-image-description="" data-medium-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=300%2C164" data-large-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=750%2C411" /><span class="yarpp-thumbnail-title">World&#8217;s Fastest Car Review: 2014 Mazda5</span></a>
<a class='yarpp-thumbnail' href='http://thegarageblog.com/garage/second-annual-mazda-adventure-rally-wrap-up/' title='Second Annual Mazda Adventure Rally wrap-up'>
<img width="120" height="120" src="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?resize=120%2C120" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="" srcset="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?resize=150%2C150 150w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?resize=100%2C100 100w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?resize=120%2C120 120w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?zoom=2&amp;resize=120%2C120 240w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?zoom=3&amp;resize=120%2C120 360w" sizes="(max-width: 120px) 100vw, 120px" data-attachment-id="23242" data-permalink="http://thegarageblog.com/garage/second-annual-mazda-adventure-rally-wrap-up/gg_mazdarally-11/" data-orig-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?fit=1200%2C800" data-orig-size="1200,800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;5.6&quot;,&quot;credit&quot;:&quot;Gary Grant&quot;,&quot;camera&quot;:&quot;Canon EOS 7D&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1402517056&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;32&quot;,&quot;iso&quot;:&quot;100&quot;,&quot;shutter_speed&quot;:&quot;0.008&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="gg_mazdarally-11" data-image-description="" data-medium-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?fit=300%2C200" data-large-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/gg_mazdarally-11.jpg?fit=750%2C500" /><span class="yarpp-thumbnail-title">Second Annual Mazda Adventure Rally wrap-up</span></a>
</div>
</div>
<!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/"
    dc:identifier="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/"
    dc:title="2018 Mazda MX-5 RF on ice"
    trackback:ping="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/trackback/" />
</rdf:RDF>-->
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://thegarageblog.com/garage/category/reviews/new-car-reviews/" rel="category tag">New car reviews</a>, <a href="http://thegarageblog.com/garage/category/video-links/" rel="category tag">Video</a></span> <span class="entry-tags">Tagged With: <a href="http://thegarageblog.com/garage/tag/coupe/" rel="tag">coupe</a>, <a href="http://thegarageblog.com/garage/tag/ice-storm/" rel="tag">ice-storm</a>, <a href="http://thegarageblog.com/garage/tag/mazda/" rel="tag">mazda</a>, <a href="http://thegarageblog.com/garage/tag/mazda-mx5/" rel="tag">mazda mx5</a>, <a href="http://thegarageblog.com/garage/tag/mazda-mx5-rf/" rel="tag">mazda mx5 rf</a>, <a href="http://thegarageblog.com/garage/tag/mazda-canada/" rel="tag">mazda-canada</a>, <a href="http://thegarageblog.com/garage/tag/miata/" rel="tag">miata</a>, <a href="http://thegarageblog.com/garage/tag/ontario/" rel="tag">ontario</a>, <a href="http://thegarageblog.com/garage/tag/roadster/" rel="tag">roadster</a>, <a href="http://thegarageblog.com/garage/tag/winter-driving/" rel="tag">winter driving</a>, <a href="http://thegarageblog.com/garage/tag/zoom-zoom/" rel="tag">zoom zoom</a></span></p><div class="after-entry widget-area"><div class="wrap"><section id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TG after post responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4693375559701553"
     data-ad-slot="6107909332"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
</div></div></footer></article>
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/garage/2018-mazda-mx-5-rf-on-ice/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="http://jetpack.wordpress.com/jetpack-comment/?blogid=1975162&#038;postid=28058&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=6.0&#038;sig=0f6a871562b7564119c900c7d9b8419d17747e3d#parent=http%3A%2F%2Fthegarageblog.com%2Fgarage%2F2018-mazda-mx-5-rf-on-ice%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="text-9" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Advertisment</h4>
			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- TGG sidebar responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4693375559701553"
     data-ad-slot="3154442931"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div></section>
<section id="media_image-7" class="widget widget_media_image"><div class="widget-wrap"><a href="http://thegarageguy.ca" target="_blank"><img width="1147" height="1093" src="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?fit=1147%2C1093" class="image wp-image-26307 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?w=1147 1147w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?resize=300%2C286 300w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?resize=768%2C732 768w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?resize=750%2C715 750w" sizes="(max-width: 1147px) 100vw, 1147px" data-attachment-id="26307" data-permalink="http://thegarageblog.com/garage/tgg-big-head/" data-orig-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?fit=1147%2C1093" data-orig-size="1147,1093" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="TGG big head" data-image-description="" data-medium-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?fit=300%2C286" data-large-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/TGG-big-head.jpg?fit=750%2C715" /></a></div></section>
<section id="search-4" class="widget widget_search"><div class="widget-wrap"><h4 class="widget-title widgettitle">Find stuff</h4>
<form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://thegarageblog.com/garage/" role="search"><meta itemprop="target" content="http://thegarageblog.com/garage/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="Search the site ..." /><input type="submit" value="Search"  /></form></div></section>
		<section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">		<h4 class="widget-title widgettitle">Recent Posts</h4>
		<ul>
											<li>
					<a href="http://thegarageblog.com/garage/2018-mazda-mx-5-rf-on-ice/">2018 Mazda MX-5 RF on ice</a>
									</li>
											<li>
					<a href="http://thegarageblog.com/garage/nyias-race-cars-gallery/">NYIAS Race Cars Gallery</a>
									</li>
											<li>
					<a href="http://thegarageblog.com/garage/new-york-international-auto-show-its-electric/">New York International Auto Show &#8211; It&#8217;s Electric!</a>
									</li>
											<li>
					<a href="http://thegarageblog.com/garage/mazda-is-ready-to-sell-the-2018-mazda6/">Mazda is Ready to Sell the 2018 Mazda6</a>
									</li>
											<li>
					<a href="http://thegarageblog.com/garage/vw-not-long-for-this-world/">VW Beetle Not Long for This World</a>
									</li>
					</ul>
		</div></section>
<section id="featured-post-10" class="widget featured-content featuredpost"><div class="widget-wrap"><h4 class="widget-title widgettitle">NEW Feature: World&#8217;s Fastest Car Review</h4>
<article class="post-23100 post type-post status-publish format-standard has-post-thumbnail category-featured-stories category-worlds-fastest-car-review tag-autonomous-car tag-autonomous-volvo tag-gothenburg tag-self-driving-car tag-self-driving-volvo tag-sweden tag-volvo tag-volvo-drive-me tag-volvo-drive-me-project entry"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/" class="alignleft" aria-hidden="true"><img width="100" height="100" src="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?resize=100%2C100" class="entry-image attachment-post" alt="World&#8217;s Fastest Car Review: Volvo Drive Me" itemprop="image" srcset="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?resize=150%2C150 150w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?resize=100%2C100 100w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?zoom=2&amp;resize=100%2C100 200w, https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?zoom=3&amp;resize=100%2C100 300w" sizes="(max-width: 100px) 100vw, 100px" data-attachment-id="23101" data-permalink="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/drive-me/" data-orig-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?fit=1277%2C711" data-orig-size="1277,711" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="drive me" data-image-description="" data-medium-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?fit=300%2C167" data-large-file="https://i1.wp.com/thegarageblog.com/garage/wp-content/uploads/drive-me.jpg?fit=750%2C417" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/">World&#8217;s Fastest Car Review: Volvo Drive Me</a></h2><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2014-05-29T10:33:41+00:00">May 29, 2014</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-volvo-drive-me/#comments">1 Comment</a></span></p></header></article><article class="post-23089 post type-post status-publish format-standard has-post-thumbnail category-featured-stories category-video-links category-worlds-fastest-car-review tag-2014-volkswagen-touareg-tdi tag-diesel tag-eric-novak tag-suv tag-volkswagen tag-vw entry"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/" class="alignleft" aria-hidden="true"><img width="100" height="100" src="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?resize=100%2C100" class="entry-image attachment-post" alt="World&#8217;s Fastest Car Review: Enviro Dad and the VW Touareg TDI" itemprop="image" srcset="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?resize=150%2C150 150w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?resize=100%2C100 100w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?zoom=2&amp;resize=100%2C100 200w, https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?zoom=3&amp;resize=100%2C100 300w" sizes="(max-width: 100px) 100vw, 100px" data-attachment-id="23090" data-permalink="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/enviro-vw/" data-orig-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?fit=1271%2C702" data-orig-size="1271,702" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="enviro vw" data-image-description="" data-medium-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?fit=300%2C165" data-large-file="https://i0.wp.com/thegarageblog.com/garage/wp-content/uploads/enviro-vw.jpg?fit=750%2C414" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/">World&#8217;s Fastest Car Review: Enviro Dad and the VW Touareg TDI</a></h2><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2014-05-26T12:08:19+00:00">May 26, 2014</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-enviro-dad-and-the-vw-touareg-tdi/#respond">Leave a Comment</a></span></p></header></article><article class="post-22940 post type-post status-publish format-standard has-post-thumbnail category-featured-stories category-new-car-reviews category-video-links category-worlds-fastest-car-review tag-savethemanuals tag-mazda tag-mazda-5 tag-mazda5 tag-minivan tag-not-a-minivan tag-save-the-manuals entry"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/" class="alignleft" aria-hidden="true"><img width="100" height="100" src="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=100%2C100" class="entry-image attachment-post" alt="World&#8217;s Fastest Car Review: 2014 Mazda5" itemprop="image" srcset="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=150%2C150 150w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?resize=100%2C100 100w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?zoom=2&amp;resize=100%2C100 200w, https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?zoom=3&amp;resize=100%2C100 300w" sizes="(max-width: 100px) 100vw, 100px" data-attachment-id="22941" data-permalink="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/wf-m5/" data-orig-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=1275%2C700" data-orig-size="1275,700" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="WF M5" data-image-description="" data-medium-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=300%2C164" data-large-file="https://i2.wp.com/thegarageblog.com/garage/wp-content/uploads/WF-M5.jpg?fit=750%2C411" /></a><header class="entry-header"><h2 class="entry-title" itemprop="headline"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/">World&#8217;s Fastest Car Review: 2014 Mazda5</a></h2><p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2014-05-08T10:56:36+00:00">May 8, 2014</time> By <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://thegarageblog.com/garage/author/admin-2/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Gary Grant</span></a></span> <span class="entry-comments-link"><a href="http://thegarageblog.com/garage/worlds-fastest-car-review-2014-mazda5/#comments">1 Comment</a></span></p></header></article></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2018 &#x000B7; <a href="http://my.studiopress.com/themes/magazine/">Magazine Pro Theme</a> on <a href="https://www.studiopress.com/">Genesis Framework</a> &#x000B7; <a href="https://wordpress.org/">WordPress</a> &#x000B7; <a href="http://thegarageblog.com/garage/wp-login.php">Log in</a></p></div></footer></div>	<div style="display:none">
	</div>
<script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "slide",directionNav: 1,controlNav: 1,animationDuration: 800,slideshowSpeed: 4000    });  });</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/thegarageblog.com\/garage\/2018-mazda-mx-5-rf-on-ice\/":28058};
	</script>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='yarppRelatedCss-css'  href='http://thegarageblog.com/garage/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.9.5' type='text/css' media='all' />
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201817'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Apraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/genesis-responsive-slider/js/jquery.flexslider.js?ver=0.9.5'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/thegarageblog.com\/garage\/wp-admin\/admin-ajax.php","nonce":"97cce8c3c1","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/thegarageblog.com\/garage\/wp-login.php?redirect_to=http%3A%2F%2Fthegarageblog.com%2Fgarage%2F2018-mazda-mx-5-rf-on-ice%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20170209'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.0'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.0'></script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=6.0'></script>
<script async="async" type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/akismet/_inc/form.js?ver=4.0.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://thegarageblog.com/garage/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.0'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=20171126#ver=20171126' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=1975162&postid=28058&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.0&sig=0f6a871562b7564119c900c7d9b8419d17747e3d#parent=http%3A%2F%2Fthegarageblog.com%2Fgarage%2F2018-mazda-mx-5-rf-on-ice%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=1975162&postid=28058&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=6.0&sig=0f6a871562b7564119c900c7d9b8419d17747e3d#parent=http%3A%2F%2Fthegarageblog.com%2Fgarage%2F2018-mazda-mx-5-rf-on-ice%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201817.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.0',blog:'1975162',post:'28058',tz:'-4',srv:'thegarageblog.com'} ]);
	_stq.push([ 'clickTrackerInit', '1975162', '28058' ]);
</script>
</body></html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/


Served from: thegarageblog.com @ 2018-04-26 18:14:25 by W3 Total Cache
-->